Degraded performance in several subsystems
Incident Report for MOBI
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 21:56 UTC
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 21:53 UTC
Update
We are continuing to investigate this issue.
Posted Jul 18, 2024 - 21:48 UTC
Investigating
We are currently investigating this issue.
Posted Jul 17, 2024 - 02:34 UTC
This incident affected: Admin and Email and notifications.